We are here to help!

You can browse through our list of Frequently Asked Questions.

Do I need any additional plugins for The PM Exam Simulator™?

Follow

You don't need any additional plugins. The PM Exam Simulator™ is a web-based simulator. There is nothing to install.

All you need is an internet connection and the most recent version of your browser - Internet Explorer 11, FireFox Quantum or Google Chrome 70.0. and Safari 12.0 Learn more

Was this article helpful?
0 out of 0 found this helpful

Comments